25 thoughts on “Router Admin Page Cannot be Displayed (Solved)

  1. We are asked to.put in the pin number from the label of the WNDR3400v2. But there is no pin number on label. We have looked everywhere on the router and nothing. It also ask for a security key which we don’t have. Our computer will not go to WiFi so therefore we cannot get the internet. It says Netgear 21 is available but it will not connect. Please help us if you can. It is so frustrating. I downladed Windows 10 and it somehow took Netgear off. I went back to Windows 8 butvstillhave problem.

    Reply
    1. We think that you have forgotten the Wifi security password. Here is the procedure to enable Wifi.

      First, reset the router to factory defaults. Follow this tutorial. After doing this step, try to connect to Netgear 21 (in your case) which won’t ask you to enter the security key since it is open to all.

      Second, login to router. Check this tutorial.

      Third, finally try to create Wifi security password. Tutorial here.

      Hope this helps.

      Reply
  2. Trying to access netgear login using my android phone. And is not finding the page ? I’m trying to change the password without having to reset the router manually. Please help me !!

    Reply
  3. I always used the netgear router to boost the signal in my home in areas where there was weak coverage. Worked brilliantly.

    Just moved home and have a new Verizon primary router…new network etc. Not sure how to ensure the Netgear router picks up the signal from the new network.

    Can you advise? I tried to access routerlogin.net but could not be found…..

    Reply
    1. Got your issue. You need to know how to configure dual router. Will do a dedicated tutorial on the same very soon. Thanks for letting us know.

      Reply
  4. I’m having trouble with my internet connection. I was able to log onto the routerlogin page from my windows phone. However, I was unable to do this from my computer. On my phone the screen said my router had no internet connection. The connection was working fine a few weeks ago.

    Reply
  5. We received a netgear 300 from my son for Christmas and have spent the last two days trying to get it set up. I’m stuck on step 2 above as we don’t get a screen which allows us to select the properties. We did spend about an hour on the phone with ‘tech support’ today and she finally advised that we must have a faulty device. I sincerely doubt that so I hope you can assist.

    Thank you so much.

    Frustrated in Florida.

    Reply
  6. Addendum: we re just able to get through step 2 completely and we still receive the message that the routerlogin.net page is unable to be displayed.

    Thank you.

    Reply
  7. I am getting this as well on a 3400 router. It worked fine a couple of weeks ago. I’ve been in IT for 30 years. The IP is right. I can connect to it. After restarting it I can get to the admin page briefly and see the menu on the side, but not the main page. the main body of the page shows as ‘cannot display..” shortly after trying a couple of menu tabs the whole thing becomes “cannot display”. Resetting will get the initial login back, but then again does not show the main portion of the page with the details. I could reset the router but then I have to re-do all the reserved addresses, port forwards, etc. Strangely this happens on Win xp, win 10, win 7. on Chrome, IE 8, IE 11. no difference but I do feel it is something that is being blocked. Turning off the firewall and popup blocker doesn’t help either.

    Reply
  8. i have forgot my wifi username and password so i hold reset button for 30 second so it told in ur official website that it leads to default username and password i.e.username=admin,password=password .i entered the same but it is saying username and password are not correct…………pls help me

    Reply
  9. have a problem with wireless not broadcasting the ssid,i rebooted the router but the only led light working is for power n may be the LAN port connected to the pc,please help

    Reply
  10. I followed correctly entered the numbers. It still gives me the page cannot be found. And even though I do not revert the changes back, it still connects to the internet.

    Reply
  11. Please! I have spent more than 5 hours today to try to solve this issue. I forget my password so I reset the router. after that it did not work at all. I have reset it more than 5 times already. I called netgear but they want me to pay in order to help me access routerlogin.net. I tried your steps but it did not work for me.

    Reply
  12. Followed the steps, setup the default gateway as per instructions, still unable to connect to 192.168.1.1 – it just times out.
    Please advise. I try the Genie software and that just breaks my connections completely. When I log in normally, I can access the web through the Netgear N300 router (through the Ethernet cable) but as soon as I try to run Genie it mucks everything up and I have to restart my computer to get any connectivity.
    Despite being able to access the Internet, I am not able to configure the router or enable WiFi on it – which is why I purchased the router.

    Reply

Post Comment